Get started with Drupal 7


No se pudo bloquear la base de datos en Manjaro

Hace unos días Manjaro sufrió una actualización importante de la distribución. Al ser una distribución rolling release , no podemos hablar de saltos de versión, pero este tipo de actualizaciones es lo más parecido a los saltos de versión que tenemos en Ubuntu.
No se pudo bloquear la base de datos en Manjaro, error manjaro

Nada más encender el ordenador, el sistema de actualizaciones de Manjaro me indica que tengo una actualización. Al aceptar la actualización comienza la descarga de un montón de paquetes (unos 300mb) y como no tenía tiempo porque ya me tenía que ir, cancelé la actualización una vez iniciada y apagué el ordenador.

El resultado de esto es que una vez que volví a encender el ordenador, al intentar actualizar me saltaba el siguiente error: "No se pudo bloquear la base de datos".

Al haber apagado el ordenador sin dejar realizar las actualizaciones supe que ese error tenía que ser algo relacionado con esto. En Ubuntu a veces me salia un error similar y lo que pasaba es que el proceso de apt-get update se quedaba funcionando siempre y no se podía volver a ejecutar. Pues bien, esto mismo le pasa a Manjaro y lo que tenemos que hacer es lo mismo que hacia en Ubuntu. Finalizar el proceso y listo.

Para solucionarlo, vamos a abrir la terminal y meter unos cuantos comandos:
  1. sudo rm /var/lib/pacman/db.lck
  2. sudo pacman-mirrors -g
  3. sudo pacman -Syyu
¿Qué significan estos comandos?. Con el primero borramos un archivo que se genera al realizar una actualización y es el que nos está dando problemas. Con el segundo comando recargamos las mirrors y con el último actualizamos.



El último comando no hace falta usarlo, simplemente podemos volver a dar al botón que damos para actualizar Manjaro y listo, ya no tendremos ningún tipo de error.

Este es el primer problema que tengo desde que uso Manjaro, y es un problema que he generado yo al apagar el ordenador mientras se actualizaba. Aun así, la solución al problema es bien sencilla y una vez solucionado no he tenido más problemas. Os lo vuelvo a repetir, si estáis buscando una nueva distribución, probar Manjaro.

Pronto probaré una versión de Manjaro optimizada para los netbooks. Si me ofrece un rendimiento similar a Lubuntu, me la quedo. Un saludo

9 comentarios:

alktodostemen dijo...

No sabria darte las gracias, o si, gracias por tu articulo y solucion para mi.

Anónimo dijo...

gracias , he tenido este problema al igual que otros muchos despues de mirar por internet , se ve que es un " pequeño problema " que gracias a la comunidad , a ti se resuelve facilmente .Gracias.

Anónimo dijo...

Muchas gracias, la primera vez que pruebo manjaro y me da ese error después de actualizar, pero ya solucionado!

Anónimo dijo...

sudo: rm/var/lib/pacman/db.lck: command not found
¡Hola!, esto es lo que me sale tras seguir tus instrucciones, tengo instalado Manjaro

Salvador Chávez dijo...

He tenido el mismo problema en Apricity OS (archlinux) y tu solución me ha venido a salvar las canicas.

reneco dijo...

Funciona, se agradece, por problemas del driver AMD tuve que abandonar ubuntu y derivadas, Manjaro es la que mejor soporte da a mi hardware.

Nestor Durán dijo...

GRACIAS!!!

Anónimo dijo...

Excelente muchas gracias!!!

Saul Alonso dijo...

GRACIASS!!!

Publicar un comentario