Get started with Drupal 7


Añadir Scopes inteligentes en Ubuntu 13.04

Ya os comenté hace un mes más o menos, que en Ubuntu 13.04 no encontraríamos los Scopes inteligentes de manera predeterminada. Y sí, tal como estáis pensando algunos, que no vengan de manera predeterminada no quiere decir que no se puedan agregar. ¡Vamos a ello!.

Antes de continuar, me gustaría explicar un poco por encima que son los famosos Scopes inteligentes, para que sirven, y ya por último, explicar cómo activarlos en Ubuntu 13.04. Los Scopes inteligentes son una serie de "plugins" que podemos agregar a Unity (el Shell de Canonical), con los cuales podemos realizar diversas tareas directamente desde el propio dash de Ubuntu.

Añadir Scopes inteligentes en Ubuntu 13.04, instalar scopes inteligentes ubuntu
Hasta ahora, con el dash de Unity "tan sólo" podremos buscar aplicaciones, archivos, música, vídeos, comprar en Amazon, etc, pero gracias a los Scopes inteligentes, podremos agregar diferentes servicios a el dash de Unity, cómo buscar directamente en Google o Wikipedia desde el propio dash, acceder a algunos servicios como sound cloud, Yahho finances, etc. ¿a que pinta todo realmente bien?.

Pues bien, tenemos dos opciones, o esperar a Ubuntu 13.10 para disfrutar de los Scopes inteligentes, o directamente, instalar los Scopes inteligentes en Ubuntu 13.04. Ya que por ahora no tenemos ni una primera versión preliminar de Ubuntu 13.10, vamos a añadir los Scopes inteligentes en Ubuntu 13.04.
Por último, y antes de explicar cómo instalar los Scopes inteligentes, me gustaría explicar una cosa respecto a estos Scopes. Canonical decidió dejar para Ubuntu 13.10 los Scopes inteligentes ya que no estaban lo suficientemente probados y por tanto, podrían ser inestables en Ubuntu 13.04.


 Aun así, el desarrollo de los Scopes inteligentes para Ubuntu sigue su curso, y una vez liberado Ubuntu 13.04, podemos agregar estos Scopes inteligentes y ya desde el gestor de actualizaciones de Ubuntu, se irán actualizando para añadirse automáticamente nuevos Scopes, y solucionar problemas de estabilidad.

Si ya os habéis decidido a probar estos Scopes inteligentes en Ubuntu 13.04, tengo que deciros que tenemos dos ramas dentro de los Scopes inteligentes. Una primera rama más inestable y avanzada, y una segunda rama que se actualiza menos pero que es más estable.


Si queremos tener lo último en Scopes inteligentes en Ubuntu 13.04 y no nos importa la estabilidad de nuestro ordenador, abrimos la terminal y escribimos:
  1. sudo add-apt-repository ppa:ubuntu-unity/experimental-prevalidation
  2. sudo apt-get update
  3. sudo apt-get dist-upgrade
  4. sudo apt-get install unity-lens-* unity-scope-*
Pero si queremos añadir los Scopes inteligentes en Ubuntu 13.04 pero queremos usar una rama algo más probada aunque tarde más en llegar actualizaciones y novedades, abrimos la terminal y escribimos:
  1. sudo add-apt-repository ppa:ubuntu-unity/experimental-certified
  2. sudo apt-get update
  3. sudo apt-get dist-upgrade
  4. sudo apt-get install unity-lens-* unity-scope-*
Vale, ya hemos probado los Scopes inteligentes en Ubuntu 13.04 y queremos desinstalarlos porque no nos han gustado, se ha vuelto más lento el ordeandor, o tenemos algún tipo de inestabilidad. ¿Cómo desinstalamos los Scopes inteligentes de Ubuntu 13.04?. Simplemente abrimos la terminal y escribimos:
  1. sudo ppa-purge ppa ubuntu-unity/experimental-prevalidation
  2. sudo apt-get purge unity-scope-*
  3. sudo apt-get purge unity-lens*
O si usamos la rama "más estable"
  1. sudo ppa-purge ppa ubuntu-unity/experimental-certified
  2. sudo apt-get purge unity-scope-*
  3. sudo apt-get purge unity-lens*
Ya sabéis, si queréis probar ya los scopes inteligentes en Ubutnu 13.04, esta es la manera más sencilla de probarlos, aunque claro, aun se encuentran en desarrollo y si usáis la rama "prevalidation" tenéis muchas posibilidades de que vuestro sistema operativo se vuelva inestable. Un saludo

1 comentarios:

Andres Mejia dijo...

Hola yo instale los scopes inteligentes pero no funcionaron asi que desinstale y ahora no sirven los que tenian antes. Ya probe varios comandos y me dice que unity-lens-friends, unity-scope-home y unity-scope-help estan danados, como lo arreglo?

Gracias

Publicar un comentario